A+B Problem

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
Calculate a+b.

Input
Two integer a,b (0<=a,b<=10).

Output
Output a+b.

Sample Input
1 2
Sample Output
3
Hint
/*注意这里的a和b是从键盘输入的随机的

#include <stdio.h>
#include <stdlib.h>

int main()
{   int a,b,sum;      //这里的sum中如果不初始化为0,则其中有一个随机数
    scanf ("%d %d",&a,&b);     // scanf是从键盘输入函数
    sum=a+b;            //将a+b的之赋给sum
    printf("%d\n",sum);
    return 0;
}

运行结果:
1 2
3

Process returned 0 (0x0)   execution time : 04.531 s
Press any key to continue.

问:怎样输入输出?

答:你的程序应该从标准输入(stdin)中读取数据,而将结果写到标准输出(stdout)。比如,在C语言中你可以使用“scanf”,在C++语言中则可以使用“cin”来输入;输出可以使用C语言的“printf”或者C++语言的“cout”。

注意:不要向标准输出写入题目要求输出结果之外的其他数据,否则你会被判为“Wrong Answer”,即错误的运行结果。

你的程序也不能试图读或写任何文件,否则你可能被判为“Runtime Error”(运行时错误)或“Wrong Answer”(错误结果)。

下面是这道题的一个C++或者G++的程序。

#include //请注意include的使用,如果使用#include 在G++编译器上将出现“Compile Error”
using namespace std;
int main()
{
int a,b;
cin >> a >> b;
cout << a+b << endl;
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

碧羽o(* ̄▽ ̄*)ブ回雪

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值