POJ -3190 Stall Reservations(贪心+堆或multiset)

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i’s milking interval with two space-separated integers.
Output
Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
5
1 10
2 4
3 6
5 8
4 7
Sample Output
4
1
2
3
2
4
Hint
Explanation of the sample:

Here’s a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

很有意思的一个题。先把时间段按开始从小到大排序。然后用一个小顶堆来维护。堆里面的节点有两个元素结束时间和序号,每次对一个时间段与堆顶进行比较,如果堆顶的结束时间比其开始时间小,那么就把这个时间段放到这个节点里面,如果大就放一个新的节点到堆里面。因为每次取得都是最小的,这个过程也可以用multiset来维护。

代码如下:

#include<iostream>
#include<cstring>
#include<cmath>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<algorithm>

using namespace std;
const int MAX = 50010;
typedef pair<int,int> P;
struct Node{
    int l,r;
    int pos;
};
Node q[MAX];
int N,ans[MAX];
void solve(){
    priority_queue<P,vector<P>,greater<P>> que;
    //默认是按first进行维护,所以first存放的是结束时间
    ans[q[1].pos] = 1;
    int top = 1;
    que.push(P(q[1].r,1));
    for(int i=2;i<=N;++i){
        P v = que.top();
        if(v.first < q[i].l){
            ans[q[i].pos] = v.second;
            P tt(q[i].r,v.second);
            que.pop();
            que.push(tt);
        }
        else{
            ans[q[i].pos] = ++top;
            P tt(q[i].r,top);
            que.push(tt);
        }
    }
    cout << top << endl;
    for(int i=1;i<=N;++i){
        cout << ans[i] << endl;
    }
}
int main(void){
    cin >> N;
    for(int i=1;i<=N;++i){
        cin >> q[i].l >> q[i].r;
        q[i].pos = i;//要把原来每个时间段的序号记住。
    }
    sort(q+1,q+1+N);
    solve();
    return 0;
}

bool operator < (Node A,Node B){
    if(A.l == B.l)
        return A.r < B.r;
    else
        return A.l < B.l;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值