搜索E Find The Multiple POJ - 1426

#acm/搜索

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

如果我没理解错的话,这题是说
n是10进制数,不超过10进制200。
m是10进制数,不超过10进制100位,即 1 ≤ m ≤ 1 0 100 − 1 1\leq m\leq10^{100}-1 1m101001

long long 最大为10进制19位,20位到100位的m为什么不用考虑了呢。
考虑的话要用大数,可为啥直接用long long 就过了呢。

不用大数的话需要用G++编译,如果用C++编译需要手写队列,否则会超时。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
#include <queue>
#include <map>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
int n;
ll bfs(ll m){
    queue<ll>que;
    que.push(m);
    while(!que.empty()){
        ll head = que.front();
        que.pop();
        if(!(head % n)) return head;
        que.push(head * 10);
        que.push(head * 10 + 1);
    }
    return -1;
}

int main(){
     while(~scanf("%d", &n), n){
         cout << bfs(1) <<endl;
     }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值