Reward

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.  
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)  
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1
在题中给出的A,B,中,A大于B的工资,所以拓扑排序要逆向拓扑,起点工资为888,如果B是888,A是889;
因为给的数据太大了,所以要用邻接表。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#define g 21000
using namespace std;
struct node{
	int from,to,next;
}edge[g];
int head[g],in[g];
int dis[g],m,n,num;
void init()
{
	memset(head,-1,sizeof(head));
	memset(in,0,sizeof(in));
	num=0;
}
void add(int u,int v)
{
	edge[num].from =u;
	edge[num].to =v;
	edge[num].next =head[u];
	head[u]=num++;
}
void topo()
{
	int i,j,p=0,k,l=0,sum=0;
	queue<int> q;
	while(!q.empty() )
	q.pop() ;
	for(i=1;i<=n;i++)
	{
		if(in[i]==0)
		q.push(i); 
	}
	while(!q.empty() )
	{
		int now=q.front() ;
		q.pop() ;l++;//L是记录人数,与n比较,如果相等,则不出现环。
		for(i=head[now];i!=-1;i=edge[i].next )
		{
			int k=edge[i].to ;
			in[k]--;
			if(in[k]==0)
			{
				dis[k]=dis[now]+1;//将下一层结点含有的值加1.
 
				q.push(k); 
			}
			
		}
	}
	if(l==n)
	{
	for(j=1;j<=n;j++)
	sum+=dis[j];
	printf("%d\n",sum);
	}
	else
	printf("-1\n");
}
int main()
{
	int i,j,a,b;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		for(i=1;i<=n;i++)
		dis[i]=888;
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			add(b,a);
			in[a]++;
		}
		topo();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值