杭电2071 Max Num

题目最后要求的是输出一个最大值,边输入数据就可以边选出最大的值,另外使用动态数组比较好控制每一组所要的数组的长度,还有要注意输出的格式!!    

Problem Description
There are some students in a class, Can you help teacher find the highest student .
Input

There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.

Output

For each case output the highest height, the height to two decimal plases;
 
Sample Input

  
  
2

  
  
3 170.00 165.00 180.00

  
  
4 165.00 182.00 172.00 160.00

Sample Output

  
  
180.00

  
  
182.00

代码:

#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
int t,n,i;
double temp;
cin>>t;
for(;t>0;t--)
{
temp=0;
cin>>n;
double *q;
q=new double[n];
for(i=0;i<n;i++)
{
cin>>q[i];
if(temp<q[i])
temp=q[i];
}
cout<<fixed<<setprecision(2)<<temp<<endl;
delete []q;
}
return 0;
}




 
 
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值