题目1 : Magic Box
-
1 2 3 RRYBRBRYBRY
样例输出
-
7
描述
The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some balls into the box one by one. The balls are in three colors: red(R), yellow(Y) and blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box. Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find what is the maximum number of balls in the box ever.
For example, let's assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.
输入
Line 1: x y z
Line 2: the sequence consisting of only three characters 'R', 'Y' and 'B'.
For 30% data, the length of the sequence is no more than 200.
For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.
输出
The maximum number of balls in the box ever.
提示
Another Sample
Sample Input | Sample Output |
0 0 0 RBYRRBY | 4 |
Sunny有一个魔法盒子,把3种颜色(R Y B)的球依次盒子中,当盒子中球的数量分别为 r y b时,球的差别定义为三个数:abs(r-y) abs(r-b) abs(y-b),如果这个三个数为给定的x y z时,盒子里面的全部球就会消失,然后接着放球。
输入x y z 和放球的序列
输出整个过程中盒子中球数最多是多少
直接模拟就行了
r y b分别记录盒子中R Y B球的数量,当一个球进入盒子时,更新答案,然后求出三个差数,如果是x y z,那么清空
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int maxn = 20000 + 20;
char seq[maxn];
int num[3];
int xxx[3];
int idx(char c) {
if(c == 'R') return 0;
if(c == 'Y') return 1;
if(c != 'B') seq[-111111] = 11111;
return 2;
}
bool check() {
int t[3];
t[0] = abs(num[0] - num[1]);
t[1] = abs(num[0] - num[2]);
t[2] = abs(num[1] - num[2]);
sort(t, t+3);
for(int i = 0; i < 3; i++) {
if(t[i] != xxx[i]) return false;
}
return true;
}
int main() {
while(scanf("%d%d%d", &xxx[0], &xxx[1], &xxx[2]) != EOF) {
sort(xxx, xxx+3);
memset(num, 0, sizeof(num));
scanf("%s", seq);
int ans = 0;
int len = strlen(seq);
for(int i = 0; i < len; i++) {
num[idx(seq[i])]++;
int tans = num[0] + num[1] + num[2];
ans = max(ans, tans);
if(check()) {
num[0] = num[1] = num[2] = 0;
}
}
printf("%d\n", ans);
}
return 0;
}