Android通过Gradle发布多渠道版本遇到的Gradle版本问题解决

今天在通过Gradle发布多渠道版本的时候,遇到了Gradle版本过低导致不支持manifestPlaceholders字段的问题,想尽各种办法升级Gradle、Gradle的插件,最后终于成功了,在这里把方法分享给大家。

本人使用的是Intellij IDEA 13,Gradle版本是1.8,Gradle插件版本是0.6.+,需要将Gradle升级到2.1,插件版本升级到0.14+。遇到的错误是:

Deprecated dynamic property: "manifestPlaceholders" on "ProductFlavorDsl_Decorated{name=main, minSdkVersion=14, targetSdkVersion=19, renderscriptTargetApi=-1, versionCode=-1, versionName=null, packageName=null, testPackageName=null, testInstrumentationRunner=null, signingConfig=null}", value: "{CHANNEL_NAME=default_...".

首先将工程目录下的/gradle/wrapper/gradle-wrapper.properties文件中的distributionUrl改为(注意,在子工程目录下也会有一个/gradle/wrapper/gradle-wrapper.properties文件,可以一并修改):

distributionUrl=http\://services.gradle.org/distributions/gradle-2.1-bin.zip

其次,在终端进入工程目录,运行命令更新Gradle:

./gradlew wrapper

更新完之后,修改build.gradle文件中的gradle插件版本为:

dependencies {
        classpath 'com.android.tools.build:gradle:0.14+'
    }

接着在终端工程目录运行命令更新插件:

./gradlew assembleDebug

过程中有可能会报错:

The SDK Build Tools revision (17.0.0) is too low for project ':xdp_android'. Minimum required is 19.1.0

此时需要在Android SDK Manager中下载SDK Build Tools 19.1.0并安装。安装完成后,再次执行assembleDebug即可成功。


如果大家觉得对自己有帮助的话,还希望能帮顶一下,谢谢:)
个人博客:http://blog.csdn.net/zhaoxy2850
本文地址:http://blog.csdn.net/zhaoxy_thu/article/details/43990627
转载请注明出处,谢谢!

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页