Ice_cream's world I
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
Sample Output
3
题意:女王 要给ACMER分地,女王的土地中有很多瞭望塔,女王命令下人在瞭望塔(watchtower) 与瞭望塔之间建立笔直的围墙,被围墙圈起来的土地可以用来奖励ACMER,但是女王不知道最多能奖励多少ACMER,简单的说就是判断形成环的数量。通过并查集判断联通的个数就行了。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[1010];
int getf(int u)
{
if(u!=f[u])
f[u]=getf(f[u]);
return f[u];
}
int mer(int u,int v)
{
int t1=getf(u);
int t2=getf(v);
if(t1!=t2)
{
f[t1]=t2;
return 0;
}
return 1;
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
int i,j;
for(i=0;i<=n;i++)
f[i]=i;
int a,b,sum=0;
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
sum+=mer(a,b);
}
printf("%d\n",sum);
}
}