UESTC Training for Data Structures——B

Problem  B

Problem Description

  Polycarp thinks about the meaning of life very often. He does this constantly, even when typing in the editor. Every time he starts brooding he can no longer fully concentrate and repeatedly presses the keys that need to be pressed only once. For example, instead of the phrase "how are you" he can type "hhoow aaaare yyoouu".

  Polycarp decided to automate the process of correcting such errors. He decided to write a plug-in to the text editor that will remove pairs of identical consecutive letters (if there are any in the text). Of course, this is not exactly what Polycarp needs, but he's got to start from something!

  Help Polycarp and write the main plug-in module. Your program should remove from a string all pairs of identical letters, which are consecutive. If after the removal there appear new pairs, the program should remove them as well. Technically, its work should be equivalent to the following: while the string contains a pair of consecutive identical letters, the pair should be deleted. Note that deleting of the consecutive identical letters can be done in any order, as any order leads to the same result.

Input

The first line is an integer T(T<=50)--The number of test cases.
For each of the test case,there is a single string,the length of the line is from 1 to 2*10^5 characters inclusive. The string contains only lowercase Latin letters.

Output

For each of the test case,print the given string after it is processed.It is guaranteed that the result will contain at least one character.

Sample Input

3
hhoowaaaareyyoouu
reallazy
abacabaabacabaa

Sample Output

wre
rezy
a
/*由于当时不怎么会用stack,于是建了一个循环链表,然后从最初的位子开始往后扫描,遇到相同的,两个同时
删除,这样操作以后就得到了正解*/

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#define N 200005
#define INF 1e10
#include<ctime>
#include<cstdlib>
using namespace std;
int main()
{
    int t;
    char a[N];
    int pre[N],next[N],tot;
    scanf("%d",&t); gets(a);
    for(int ca=1;ca<=t;ca++)
    {
        int n=0; char ch;
        while(scanf("%c",&ch),ch!='\n') a[++n]=ch;
        for(int i=1;i<=n;i++)  //建循环队列
        {
            pre[i]=i-1;
            next[i]=i+1;
        }
        next[0]=1; pre[n+1]=n;
        int i=1;  //查找相同的元素,删除
        while(i>0 && i<n+1)
        {
            while(i>0 && a[i]==a[next[i]])
            {
                next[pre[i]]=next[next[i]];
                pre[next[next[i]]]=pre[i];
                i=pre[i];
            }
            i=next[i];
        }
        i=next[0];
        while(i!=n+1)  //输出队列中还剩下的元素
        {
            printf("%c",a[i]);
            i=next[i];
        }
        printf("\n");
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值