UESTC Training for Data Structures——F

Problem  F

Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

  Some of Farmer John\'s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows\' heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.

Input

The first line is the number of test cases T(T<=20).
For each of the test case:
Line 1: The number of cows, N.
Lines 2 Contains N integers that is the height of every cow from left to right.

Output

For each of the test case,output a single integer that is the sum of c1 through cN.

Sample Input

1
6
10 3 7 4 12 2

Sample Output

5
/*维护一个严格递减的栈,统计每个元素比他大的数的数量,相加求和即是答案*/

#include<iostream>
#include<cstring>
#include<cmath>
#include<stdio.h>
#include<stack>
#define N 100005
using namespace std;
int main()
{
    int n,t;
    scanf("%d",&t);
    for(int ca=1;ca<=t;ca++)
    {
        int a[N];
        stack<int>s;
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        s.push(a[1]); __int64 ans=0;
        for(int i=2;i<=n;i++)
        {
            while(!s.empty() && s.top()<=a[i]) s.pop();
            ans+=(__int64)s.size();
            s.push(a[i]);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


 

 

互联网络程序设计是指在互联网上进行程序开发和设计的过程。UESTC则是我国的一所著名高校——电子科技大学。 互联网络程序设计 uestc包含了两个主要的方面:互联网络和程序设计。互联网络是指将多个计算机网络通过通信链路互相连接起来,实现信息共享和资源共享的网络系统。程序设计是指根据需求和目标,通过编写代码和设计算法,实现计算机程序的过程。 互联网络程序设计 uestc的学习内容主要包括以下几个方面: 1. 网络知识:学习互联网络的基本概念、原理和协议,如TCP/IP协议、HTTP协议等。掌握网络编程的基本技术,能够编写网络应用程序。 2. 数据通信:学习数据通信的基本原理和技术,包括数据传输的方式、数据压缩和加密等。了解网络安全和数据保护的基本知识。 3. 程序设计:学习编程语言和开发工具,如Java、C++和Python等。掌握常用的编程技巧和方法,能够设计和实现复杂的网络应用程序。 4. Web开发:学习Web开发的基本知识和技术,包括HTML、CSS、JavaScript等。能够设计和实现交互式的Web应用程序。 5. 数据库技术:学习数据库的基本原理和技术,如SQL语言和数据库管理系统。能够设计和管理数据库,实现数据的存储和检索。 通过学习互联网络程序设计 uestc,可以掌握互联网应用开发的基本技能,具备设计和实现网络应用程序的能力。这对于目前互联网行业的人才需求来说是非常重要的,也为学生提供了广阔的就业和创业机会。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值