UESTC Training for Data Structures——F

Problem  F

Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

  Some of Farmer John\'s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows\' heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.

Input

The first line is the number of test cases T(T<=20).
For each of the test case:
Line 1: The number of cows, N.
Lines 2 Contains N integers that is the height of every cow from left to right.

Output

For each of the test case,output a single integer that is the sum of c1 through cN.

Sample Input

1
6
10 3 7 4 12 2

Sample Output

5
/*维护一个严格递减的栈,统计每个元素比他大的数的数量,相加求和即是答案*/

#include<iostream>
#include<cstring>
#include<cmath>
#include<stdio.h>
#include<stack>
#define N 100005
using namespace std;
int main()
{
    int n,t;
    scanf("%d",&t);
    for(int ca=1;ca<=t;ca++)
    {
        int a[N];
        stack<int>s;
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        s.push(a[1]); __int64 ans=0;
        for(int i=2;i<=n;i++)
        {
            while(!s.empty() && s.top()<=a[i]) s.pop();
            ans+=(__int64)s.size();
            s.push(a[i]);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值