1020 Tree Traversals (25分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
本题思路:给定一个二叉树的先序序列和中序序列或者给定中序序列和后序序列都能够唯一的确定一棵二叉树。本题中构建二叉树是运用递归的思想,每次通过一段后序序列的最后一个元素得到二叉树的一部分的根节点,然后查找它在中序序列的位置,并且与左右界限判断就可以确定该根节点是否有左右子树,递归处理。最后的左右子节点映射关系用map来存。层次遍历直接用bfs就可以了
#include<iostream>
#include<algorithm>
#include<unordered_map>
using namespace std;
const int N=35;
int inorder[N],q[N],postorder[N];
int n;
unordered_map<int,int> l,r,pos;
int build(int il,int ir,int pl,int pr)
{
int root=postorder[pr];
int k=pos[root];
if(il<k) l[root]=build(il,k-1,pl,pl+(k-1-il));
if(k<ir) r[root]=build(k+1,ir,pl+(k-1-il)+1,pr-1);
return root;
}
void bfs(int root)
{
int hh=0,tt=0;
q[0]=root;
while(hh<=tt)
{
int t=q[hh++];
if(l.count(t))
q[++tt]=l[t];
if(r.count(t))
q[++tt]=r[t];
}
for(int i=0;i<n;i++)
{
if(i!=0)
printf(" ");
printf("%d",q[i]);
}
}
int main()
{
cin >>n;
for(int i=0;i<n;i++)
scanf("%d",&postorder[i]);
for(int i=0;i<n;i++)
{
scanf("%d",&inorder[i]);
pos[inorder[i]]=i;
}
int root=build(0,n-1,0,n-1);
bfs(root);
return 0;
}