1078 Hashing (25分)
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10^4 ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.
Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
本题思路:本题主要是要理解二次探测,
f(key) = (f(key)+di) MOD k (di = 1^2, -1^2, 2^2, -2^2,……, q^ 2 , -q ^ 2 , q < k)
本题中说明了只有正增量,因此式子中的负项不用考虑
AC代码:
#include<iostream>
#include<algorithm>
#include<unordered_map>
#include<unordered_set>
#include<cmath>
using namespace std;
bool isprime(int t)
{
if(t<2)
return false;
for(int i=2;i*i<=t;i++)
if(t%i==0)
return false;
return true;
}
int k,n;
unordered_set<int> ans;
int main()
{
cin >> k >> n;
if(!isprime(k))
{
while(!isprime(k))
k++;
}
for(int i=0;i<n;i++)
{
if(i!=0)
printf(" ");
int t;
cin >> t;
t=t%k;
if(ans.find(t)==ans.end()) //没有发生冲突
{
printf("%d",t);
ans.insert(t);
}
else //一开始有冲突
{
bool flag=false;
for(int i=1;i<k;i++) //二次探测
{
int p=(t+i*i)%k;
if(ans.find(p)==ans.end())
{
flag=true;
ans.insert(p);
printf("%d",p);
break;
}
}
if(!flag)
printf("-");
}
}
return 0;
}