poj1442blacks boxs【treap树】

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9883 Accepted: 4047

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.


Let us describe the sequence of transactions by two integer arrays:


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source


1A~果然上午看小说,中午吃好吃的,下午效率高23333

说题意,有两种操作 add和query,query每次查询的是第i小的,i是从0开始的,查询之前i++,查询之后不删除。告诉你add数字的依次次序,又告诉你当数组当前有几个数的时候进行了一次查询(这句话我结合示例看了好久才明白什么意思)然后就是小case了

/*************
poj1442
2016.1.26
984K	204MS	C++	2246B
*************/
#include <cstdio>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <utility>
#include <vector>
#include <queue>
#include <map>
#include <set>
#define max(x,y) ((x)>(y)?(x):(y))
#define min(x,y) ((x)>(y)?(y):(x))
#define INF 0x3f3f3f3f
#define MAXN 100005

using namespace std;

int cnt=1,rt=0; //节点编号从1开始

struct Tree
{
  int key, size, pri, son[2]; //保证父亲的pri大于儿子的pri
  void set(int x, int y, int z)
  {
    key=x;
    pri=y;
    size=z;
    son[0]=son[1]=0;
  }
}T[MAXN];

void rotate(int p, int &x)
{
  int y=T[x].son[!p];
  T[x].size=T[x].size-T[y].size+T[T[y].son[p]].size;
  T[x].son[!p]=T[y].son[p];
  T[y].size=T[y].size-T[T[y].son[p]].size+T[x].size;
  T[y].son[p]=x;
  x=y;
}

void ins(int key, int &x)
{
  if(x == 0)
    T[x = cnt++].set(key, rand(), 1);
  else
  {
    T[x].size++;
    int p=key < T[x].key;
    ins(key, T[x].son[!p]);
    if(T[x].pri < T[T[x].son[!p]].pri)
      rotate(p, x);
  }
}

void del(int key, int &x) //删除值为key的节点
{
  if(T[x].key == key)
  {
    if(T[x].son[0] && T[x].son[1])
    {
      int p=T[T[x].son[0]].pri > T[T[x].son[1]].pri;
      rotate(p, x);
      del(key, T[x].son[p]);
    }
    else
    {
      if(!T[x].son[0])
        x=T[x].son[1];
      else
        x=T[x].son[0];
    }
  }
  else
  {
    T[x].size--;
    int p=T[x].key > key;
    del(key, T[x].son[!p]);
  }
}

int find(int p, int x) //找出第p小的节点的编号
{
  if(p == T[T[x].son[0]].size+1)
    return x;
  if(p > T[T[x].son[0]].size+1)
    find(p-T[T[x].son[0]].size-1, T[x].son[1]);
  else
    find(p, T[x].son[0]);
}


int ad[30005],qu[30005];
int main()
{
  //  freopen("cin.txt","r",stdin);
    int m,n,pos,posq;
    while(~scanf("%d%d",&m,&n))
    {
        rt=0;
        cnt=1;
        for(int i=1;i<=m;i++) scanf("%d",&ad[i]);
        for(int i=1;i<=n;i++) scanf("%d",&qu[i]);
        pos=0,posq=1;
        for(int i=1;i<=m;i++)
        {
            ins(ad[i],rt);
          //  cout<<"1111111"<<endl;
            while(i==qu[posq])
            {
             //   cout<<"22222222"<<endl;
                pos++;
                int p=find(pos,rt);
                printf("%d\n",T[p].key);
                posq++;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值