hdu3469Watch The Movie【分组背包】二维dp数组

Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy.
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 

Sample Input
  
  
1 3 2 10 11 100 1 2 9 1
 

Sample Output
  
  
3
 

Source
 

这个题居然卡了一下午是因为多了一个%  --!

题意:小姑娘开学前晚上看电影只能L分钟,有N个不同的电影可以选择,傲娇老板只恰好卖M张蝶,给出每部电影时长和快乐值,问最大的快乐值是多少

百思不得其解这玩意“组”在哪里?唯一能够想到的是把不同影片看成不同组,那组内各个元素是什么?当然是作为一起选的个数了,这个也是可选个数m~0循环作为第二重循环,第三维当然就是cost[i]~第二维的数据啦

最后既然是要求恰好m个,那么dp[m][i]取最大就好啦

/*************
hdu3469
2016.3.13
31MS	1748K	940 B	G++
**************/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define inf 0x3f3f3f3f
int dp[102][1005],cost[102],value[102],t,n,m,l;
int max(int a,int b){if(a>b)return a;return b;}
int main()
{
   // freopen("cin.txt","r",stdin);
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&l);
        for(int i=1;i<=n;i++)scanf("%d%d",&cost[i],&value[i]);
        for(int i=0;i<=m;i++)
            for(int j=0;j<=l;j++)
                dp[i][j]=-0x3f3f3f3f;
        dp[m][l]=dp[0][0]=0;
        for(int i=1;i<=n;i++)
            for(int j=m;j>0;j--)
                for(int k=cost[i];k<=l;k++)
                    dp[j][k]=max(dp[j][k],dp[j-1][k-cost[i]]+value[i]);//printf("i=%d,j=%d,k=%d,dp=%d\n",i,j,k,dp[j][k]);
        for(int i=0;i<l;i++)dp[m][l]=max(dp[m][l],dp[m][i]) ;
        printf("%d\n",dp[m][l]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值