C#程序设计练习题五: 水仙花数

题目描述

春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的: “水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。 现在要求输出所有在m和n范围内的水仙花数。

输入

输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。

输出

对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于 m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开; 如果给定的范围内不存在水仙花数,则输出no; 每个测试实例的输出占一行。

样例输入

copy

100 120 
300 380

样例输出

no
370 371

提示

 

杭电2010

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication2
{
    class Program
    {
        static void Main(string[] args)
        {
            int p=1;
            while (p>0)
            {
                string s = Console.ReadLine();
                if (s == null || "".Equals(s))
                {
                    break;
                }
                string[] s1 = s.Split();
                int m = Convert.ToInt32(s1[0]);
                int n = Convert.ToInt32(s1[1]);
                wahh(m, n);
                Console.WriteLine();

            }
            Console.ReadKey();

        }

    
        static void wahh(int m, int n)
        {
            int[] akl = new int[1000];
            int flag = 0;
            int flag2 = 1;
            for (int i = m; i <= n; i++)
            {
                int sum = 0;
                int k = i;
                while (k != 0)
                {
                    int p = k % 10;
                    sum += p * p * p;
                    k = k / 10;
                    //Console.WriteLine(sum);
                }
                if (sum == i)
                {
                    flag = 1;
                    if (flag2 == 1)
                        Console.Write(sum);
                    else
                    {
                        Console.Write(" ");
                        Console.Write(sum);
                    }
                    flag2 = 0;
                }
            }
            if (flag == 0)
            {
                Console.Write("no");
            }
        }
    }
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值