Inversion II

8 篇文章 0 订阅
4 篇文章 0 订阅

 

题目描述

 Let { A1,A2,...,An } be a permutation of the set{ 1,2,..., n}. If i < j and Ai > Aj then the pair (Ai,Aj) is called an "inversion" of the permutation. For example, the permutation {3, 1, 4, 2} has three inversions: (3,1), (3,2) and (4,2).
  The inversion table B1,B2,...,Bn of the permutation { A1,A2,...,An } is obtained by letting Bj be the number of elements to the left of j that are greater than j. (In other words, Bj is the number of inversions whose second component is j.) For example, the permutation:
{ 5,9,1,8,2,6,4,7,3 }
has the inversion table
2 3 6 4 0 2 2 1 0
since there are 2 numbers, 5 and 9, to the left of 1; 3 numbers, 5, 9 and 8, to the left of 2; etc.
  Perhaps the most important fact about inversions is Marshall Hall's observation that an inversion table uniquely determines the corresponding permutation. So your task is to convert a permutation to its inversion table, or vise versa, to convert from an inversion table to the corresponding permutation.

 

输入

The input consists of several test cases. Each test case contains two lines.
The first line contains a single integer N ( 1 <= N <= 50) which indicates the number of elements in the permutation/invertion table. 
The second line begins with a single charactor either 'P', meaning that the next N integers form a permutation, or 'I', meaning that the next N integers form an inversion table. 
Following are N integers, separated by spaces. The input is terminated by a line contains N=0.

 

输出

For each case of the input output a line of intergers, seperated by a single space (no space at the end of the line). If the input is a permutation, your output will be the corresponding inversion table; if the input is an inversion table, your output will be the corresponding permutation.

 

样例输入

复制样例数据

9
P 5 9 1 8 2 6 4 7 3
9
I 2 3 6 4 0 2 2 1 0
0

样例输出

2 3 6 4 0 2 2 1 0
5 9 1 8 2 6 4 7 3

 

来源/分类

ZJU 2002, Preliminary 

 

 

 

 

 

 

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct mam
{
    int p;
    int q;
};
int cmp(mam a,mam b)
{
    return a.p<b.p;
}
int main()
{
    int n;
    char s;
    mam hh[100];
    int a[100];
    while(cin>>n&&n)
    {
        cin>>s;
        if(s=='P')
        {
            for(int i=0; i<n; i++)
            {
                cin>>hh[i].p;
                hh[i].q=0;
            }
            for(int i=0; i<n; i++)
            {
                for(int j=0; j<i; j++)
                {
                    if(hh[i].p<hh[j].p)
                        hh[i].q++;
                }
            }
            sort(hh,hh+n,cmp);
            for(int i=0; i<n-1; i++)
                cout<<hh[i].q<<" ";
            cout<<hh[n-1].q<<endl;
        }
        if(s=='I')
        {
            for(int i=1; i<=n; i++)
                cin>>a[i];
            int b[100];
            memset(b,0,sizeof(b));
            for(int i=1; i<=n; i++)
            {
                int j,k=0;
                for(j=1; j<=n; j++)
                {
                    if(k==a[i]&&b[j]==0)
                        break;
                    else if(k!=a[i]&&b[j]==0)
                        k++;
                }
                b[j]=i;

            }
            for(int z=1; z<=n; z++)
                cout<<b[z]<<" ";
            cout<<endl;


        }
    }


    return 0;
}

 

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值