A - Max Sum HDU - 1003

3 篇文章 0 订阅
 Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

很经典的一道题
题意:求和是最大的的一段连续子序列,输出和和两个区间端点
思路:两个变量sum和maxv,sum用来存每一段和不会是负数的连续子序列的和,maxv用来和sum比较,如果找到了一个sum比maxv大,maxv=sum,同时记录左端点和右端点(直接i)。sum是怎么记录的呢,初始化sum是0,在输入序列的时候,如果sum是大于等于0的就加当前元素,否则就让sum等于当前元素,用一个临时变量记录一下左端点。然后每次都要让sum和maxv比较一下(如果maxv更新,左端点就等于临时变量记录的左端点)。时间复杂度On
为什么是这种思路呢?
找到最大的和,单单用sum是不行的,sum要存每一段和不会是负数的连续子序列的和,如果加到了负数,只要sum不是负数就可以继续加,因为万一后面还有比较大的数使得就算前面有负数也能达到最大值呢;如果sum是负数,就意味着后面怎么加都会比整体都会比后面小,那就必须开始一段新的子序列,所以sum=当前元素,并记录下当前左端点。
ps:maxv初始化一定要无穷小啊

#include<iostream>
using namespace std;
int num;
int T,N;
int l,r;
int main(){
    cin>>T;
    for(int i=1;i<=T;i++){
        cin>>N;
        l=1;
        int maxv=-1e8;
        int tmpl=1;
        int sum=0;
        for(int j=1;j<=N;j++){
            cin>>num;
            if(sum>=0){
                sum+=num;
            }else{
                sum=num;
                tmpl=j;
            }
            if(sum>maxv){
                maxv=sum;
                l=tmpl;
                r=j;
            }
        }if(i!=T)
        cout<<"Case "<<i<<":"<<endl<<maxv<<" "<<l<<" "<<r<<endl<<endl;
        else
           cout<<"Case "<<i<<":"<<endl<<maxv<<" "<<l<<" "<<r<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值