Heuristic Search - 8 Puzzle(九宫格)(map判重+bfs)(康拓展开+bfs)

8 Puzzle

The goal of the 8 puzzle problem is to complete pieces on 3×33×3 cells where one of the cells is empty space.

In this problem, the space is represented by 0 and pieces are represented by integers from 1 to 8 as shown below.

1 3 0
4 2 5
7 8 6

You can move a piece toward the empty space at one step. Your goal is to make the pieces the following configuration in the shortest move (fewest steps).

1 2 3
4 5 6
7 8 0

Write a program which reads an initial state of the puzzle and prints the fewest steps to solve the puzzle.

Input

The 3×33×3 integers denoting the pieces or space are given.

Output

Print the fewest steps in a line.

Constraints

  • There is a solution.

Sample Input

1 3 0
4 2 5
7 8 6

Sample Output

4


这道题二维映射一维,使用bfs,重要在于判重,有个八数码的八境界,现在会使用map和康拓展开式判重

#include<bits/stdc++.h>

using namespace std;

#define b 3
#define n2 9

const int dx[4]={-1,0,1,0};
const int dy[4]={0,-1,0,1};
const char dir[4]={'u','l','d','r'};

struct puzzle{
    int f[n2];
    int space;
    string path;
    bool operator < (const puzzle &p)const {
        for(int i=0;i<n2;i++){
            if(f[i]==p.f[i]){
                continue;
            }
            return f[i]>p.f[i];
        }
        return false;
    }
};

bool istarget(puzzle p)
{
    for(int i=0;i<n2;i++){
        if(p.f[i]!=(i+1)){
            return false;
        }
    }
    return true;
}

string bfs(puzzle s)
{
    queue<puzzle>q;
    map<puzzle,bool>V;
    puzzle u,v;
    s.path="";
    q.push(s);
    V[s]=true;
    while(!q.empty()){
        u=q.front();
        q.pop();
        if(istarget(u)){
            return u.path;
        }
        int sx=u.space/b;
        int sy=u.space%b;
        for(int r=0;r<4;r++){
            int tx=sx+dx[r];
            int ty=sy+dy[r];
            if(tx<0||ty<0||tx>=b||ty>=b){
                continue;
            }
            v=u;
            v.space=tx*b+ty;
            swap(v.f[v.space],v.f[u.space]);
            if(!V[v]){
                V[v]=true;
                v.path+=dir[r];
                q.push(v);
            }
        }
    }
    return "unsolvable";
}

int main()
{
    puzzle in;
    for(int i=0;i<n2;i++){
        scanf("%d",&in.f[i]);
        if(in.f[i]==0){
            in.f[i]=n2;
            in.space=i;
        }
    }
    string ans=bfs(in);
    cout<<ans.size()<<endl;
    return 0;
}
/*
1 3 0
4 2 5
7 8 6
*/

还有一种判重方式为康拓展开式

康拓展开式+bfs

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值