hdu2069Coin Change

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money. 

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent. 

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins. 
InputThe input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.OutputFor each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.Sample Input
11
26

Sample Output

4
13


母函数的进阶:使用二维数组的母函数,多了一个条件

#include<iostream>
#include<cstring>

using namespace std;

typedef long long LL;

const int maxn=1e3+5;

int s[10]={0,1,5,10,25,50};

int a[maxn][105],b[maxn][105];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<=n&&i<=100;i++){
            a[i][i]=1;
        }
        for(int i=2;i<=5;i++){
            for(int j=0;j<=n;j++){
                for(int k=0;k+j<=n;k+=s[i]){
                    for(int h=0;h+(k+j)/s[i]<=100;h++){
                        b[k+j][h+(k+j)/s[i]]+=a[j][h+j/s[i]];
                    }
                }
            }
            memcpy(a,b,sizeof(a));
            memset(b,0,sizeof(b));
        }
        LL res=0;
        for(int i=0;i<=100;i++){
            res+=a[n][i];
        }
        printf("%lld\n",res);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值