hdu1213并查集

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases.
Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000).
N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow.
Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other.
There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

#include<stdio.h>
int graph[1005],n,m,a,b;
int find(int x)
{
    if(graph[x]==-1)
    {
        return x;
    }
    return graph[x]=find(graph[x]);
}
int main()
{
    int T;
    scanf("%d",&T); 
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            graph[i]=-1;
         } 
        while(m--)
        {
            scanf("%d%d",&a,&b);
            a=find(a);
            b=find(b);
            if(a!=b)
            {
                graph[a]=b;
            }
        }
        int count=0;
        for(int i=1;i<=n;i++)
        {
            if(graph[i]==-1)
            {
                count++;
            }
        }
        printf("%d\n",count);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值