Aladdin and the Flying Carpet LightOJ - 1341 (算术基本定理)

Aladdin and the Flying Carpet LightOJ - 1341

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input
2
10 2
12 2
Sample Output
Case 1: 1
Case 2: 2
算术基本定理(百度)

//算术基本定理 
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>

#define maxn 1000007
#define ll long long 

int prime[maxn];
int mark[maxn];
int count = 0; // 记录素数的总个数;

void find_prime() //素数打表,存放在prime[]数组中 
{
    for(int i = 2; i < maxn; i ++)
    {
        if( mark[i] == 0)
            {
                prime[count++] = i;

                for(int j = i + i; j < maxn; j += i)
                {
                    mark[j] = 1;
                }
            }
    }
}

int solve(ll a)
{
    if( a == 0)  return 0;

    int i = 0;
    int s = 1;

    while( i < count && prime[i] < a) // 根据算术基本定理第一条求出它所有因子的个数 
    {
        if( a % prime[i] == 0)
            {
                int cnt = 0;
                while( a % prime[i] == 0 )
                {
                    a /= prime[i];
                    cnt ++;         // 求出 a1,a2,a3..... 
                }

                s *= (cnt + 1);
            }
        i ++;
    }

    if( a > 1)         // 最后一个因子,本人认为可能是打表存放的素数有限,(该表只存到了1e6+3) 
        s *= (1 + 1);  // 导致有较大的素数为存在prime[]中,故未除去 ,而且只能是一次方(若平方会超出10^12) 

    return s;
}

int main()
{
    find_prime();
    int t;
    printf(" %d ",prime[count-1]);

    memset(mark,0,sizeof(mark));
    scanf("%d",&t);

    int k = 1;
    while( t --)
    {
        ll a,b;
        scanf("%lld%lld",&a,&b);

        if( b >= sqrt(a) )
            {
                printf("Case %d: 0\n",k++);
                continue;
            }
        else
            {
                int cnt = 0;
                for(int i = 1; i < b; i ++)  //  暴力求出比 b 的约数 
                    if( a % i == 0)
                        cnt ++; 

                ll cnt2 = solve(a) / 2;   // 因子个数除2 ,取到对数(多少对满足的个数) 
                printf("Case %d: %lld\n",k++,cnt2 - cnt); // 全部约数 - 不符合部分 
            } 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值