算术基本定理 唯一分解定理 (Aladdin and the Flying Carpet LightOJ - 1341 )

这篇博客讨论了一个关于Aladdin故事中的问题,他在进入魔法洞穴时需要解决谜题。问题转化为找到所有可能的矩形地毯,其面积为给定的整数a,且边长至少为b。通过数学和编程方法,我们可以优化解决方案,避免超时错误。文章介绍了两种不同的算法思路,一种基于素数分解,另一种更高效的方法能够通过AC(Accepted)测试。内容涵盖了因数计算、暴力枚举和数学优化策略。
摘要由CSDN通过智能技术生成

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2
10 2
12 2

Sample Output

Case 1: 1
Case 2: 2

题意:给a,求a的因数的数量(因数至少为b)

先求素数打表。

用第一条来快速求出某数的因数个数 (函数:cont);

然后暴力求小于b的。

最后前者减后者得答案。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
#define maxn 1000047
#define LL long long
LL p[maxn], prim[maxn];
int k = 0;
void find_prim()
{
    k = 0;
    for(LL i = 2; i <= maxn; i++)
    {
        if(!p[i])
        {
            prim[k++] = i;
            for(LL j = i+i; j <= maxn; j+=i)
            {
                p[j] = 1;
            }
        }
    }
}
LL cont(LL a)
{
    LL s = 1;
    if(a == 0)
    {
        return 0;
    }
    LL tt = 0;
    LL i = 0;
    while(prim[i] < a && i < k)
    {
        tt = 0;
        if(a%prim[i] == 0)
        {
            while(a%prim[i] == 0)
            {
                a/=prim[i];
                tt++;
            }
        }
        s *= tt+1;
        i++;
    }
    if(a > 1)
    {
        s *= 1+1;//一次
    }
    return s;
}
int main()
{
    LL a, b;
    int t;
    int cas = 0;
    find_prim();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&a,&b);
        int cnt = 0;
        LL num = 0, ans;
        if(b >= sqrt(a))
            ans = 0;        // b大小限定
        else
        {
            for(LL i = 1; i < b; i++) //暴力枚举[1, b]中a的约数
            {
                if(a%i == 0)
                {
                    cnt++;
                }
            }
            num = cont(a)/2;
            ans = num - cnt;
        }
        printf("Case %d: %lld\n",++cas,ans);
    }
    return 0;
}

上面比较清楚,用来学习,但是会TLE

下面能A。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>
 
using namespace std;
 
#define N 1000005
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))
typedef long long LL;
 
LL vis[N] = {1, 1, 0}, prim[N], k = 0, a, b, aa;
 
void isprim ();
 
int main ()
{
    int t;
    LL flag = 1;
    scanf ("%d", &t);
 
    isprim ();
 
    while (t--)
    {
        scanf ("%lld %lld", &a, &b);
 
        if (a / b < b)
        {
            printf ("Case %lld: 0\n", flag++);
            continue;
        }
 
        LL ans = 1, aa = a;
 
        for (LL i=0; i<k&&prim[i]*prim[i]<=a; i++)
        {
            LL cnt = 0;
 
            while (a % prim[i] == 0)
            {
                cnt++;
                a /= prim[i];
            }
            ans *= (cnt+1);
        }
 
        if (a > 1) ans <<= 1;
        ans >>= 1;//ans/2种矩形,另若为正方形,ans必为奇数,ans/2也可以去掉这种情况  
 
        for (LL i=1; i<b; i++)
            if (aa % i == 0) ans--;
        printf ("Case %lld: %lld\n", flag++, ans);
    }
    return 0;
}
 
void isprim ()
{
    for (LL i=2; i*i<=N; i++)
        if (!vis[i])
        for (LL j=i*i; j<=N; j+=i)
        vis[j] = 1;
 
    for (LL i=0; i<=N; i++)
        if (!vis[i]) prim[k++] = i;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值