Goldbach`s Conjecture LightOJ - 1259 (素数筛选法)

Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input
Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1) Both a and b are prime
2) a + b = n
3) a ≤ b

Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Hint
1. An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …

这道题显示超内存,后又是超内存。。。
1,首先找出素数,并存放在数组prime[] 中,(如果直接搜的话会超时)
2,标记是否为素数的数组用bool类型,否则超内存,prime[] 数组应比mark[] 数组小,否则也超内存。
3,这道题不难,细节多了也就难了,平时还是要多注意细节问题。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<algorithm>

#define ll long long
#define inf 0x3f3f3f3f
#define maxn 10000007  // 1e7+7

using namespace std;
bool mark[maxn];
int prime[maxn/10];
int cnt = 0;

void find_prime()
{
    mark[0] = true;
    mark[1] = true;

    for(int i = 2; i < maxn; i ++)  
    {
        if(mark[i] == false)
        {
            prime[cnt++] = i;
            for(int j = i + i; j < maxn; j += i)
            {
                mark[j] = true;
            }
        }
    }
}

int main()
{
    int t;
    int n;
    find_prime();
//  printf("cnt = %d\n",cnt);
    scanf("%d",&t);
    for(int i = 1; i <= t; i ++)
    {
        scanf("%d",&n);
        int tmp = n / 2;
        int cnt = 0;
        for(int j = 0; prime[j] <= tmp; j ++)
            if(mark[ prime[j] ] == 0 && mark[ n - prime[j] ] == 0)
                cnt ++;
        printf("Case %d: %d\n",i,cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值