A1067. Sort with Swap(0,*) (25)

1067. Sort with Swap(0,*) (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9
索引数字反向存储,每次枚举第一个位置是否为0,为0在枚举未归位后是否有数字,没有则说明已排好
#include<cstdio>
#include<algorithm>

using namespace std;
const int maxn = 1e5 + 10;
int main()
{
	int a[maxn];
	int n, temp, k = 1, ans = 0;//k保存未归位数的最小值  ans保存交换次数 
	scanf("%d", &n);
	int count = n - 1;
	for(int i = 0; i < n; ++i)
	{
		scanf("%d", &temp);
		a[temp] = i;
	} 
	while(1)
	{
		while(a[0] != 0)
		{
			swap(a[0], a[a[0]]);//交换0与a[0] 
			ans++;
			count--;
		}
		while(k < n)
		{
			if(a[k] != k)
			{
				swap(a[0], a[k]);//交换0与k的位置
				ans++;
				break;
			}
			++k;
		}
		if(k == n)      //k到达最后一个数的下一位置,说明都已归位 
			break;
	}
	printf("%d\n", ans);
	return 0;
}


/*    //殊途同归1
using namespace std;
const int maxn = 1e5 + 10;
int a[maxn], ans, n, k;

int main()
{
	ans = 0, k = 1;
	int temp;//temp接收索引, k 代表未归位的最小数 
	scanf("%d", &n);
	int count = n - 1;
	for(int i = 0; i < n; ++i)
	{
		scanf("%d", &temp);
		a[temp] = i;
		if(temp != 0 && temp == i)
			count--;
	}
	while(count > 0)
	{
		while(a[0] != 0)
		{
			temp = a[0];
			swap(a[0], a[temp]);
			ans++; 
		}
		for(int i = k; i < n; ++i)
		{
			if(a[i] != i)
			{
				swap(a[0], a[i]);
				k = i;
				ans++;
				break;
			}
			if(i == n-1)
			{
				printf("%d\n", ans);
				return 0;
			}
		}
	}
	return 0;
}
*/
/*           //殊途同归2
int main()
{
	ans = 0, k = 1;// k 代表未归位的最小数 
	scanf("%d", &n);
	int temp, count = n - 1;//temp接收索引
	for(int i = 0; i < n; ++i)
	{
		scanf("%d", &temp);
		a[temp] = i;
		if(temp != 0 && temp == i)
		{
			count--;
		}
	}
	while(count > 0)
	{
		if(a[0] == 0)
		{
			while(k < n)
			{
				if(a[k] != k)
				{
					swap(a[0], a[k]);
					ans++;
					break;
				}
				++k;
			}
		}
		while(a[0] != 0)
		{
			swap(a[0], a[a[0]]);
			ans++;
			count--;
		}
	}
	printf("%d\n", ans);
	return 0;
}
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值