POJ 1724 ROADS (dfs+剪枝+邻接表)

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest pathfrom the city 1 to the city N  that he can affordwith the amount of money he has. 
Input
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
Output
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 
Sample Input
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
Sample Output
11

参考链接:数组建立邻接表的方法

#include<stdio.h>
#define inf 0x3f3f3f3f
#include<string.h>
int k,n,r;
int vis[50000];
int head[50000];
int maxn,len;
struct note
{
	int u,v,l,w;
	int next;
}q[50000];
void creat(int u,int v,int l,int w)
{
	q[len].v=v;
	q[len].l=l;
	q[len].w=w;
	q[len].next=head[u];    //head记录编号,比如·u=1,存入多组数据,head[u]=-1,head[u]=1,head[u]=2......。 
	head[u]=len++;
}
void dfs(int pos,int l,int c)
{
	if(c>k||l>maxn)return;
	if(pos==n)
	{
		if(l<maxn)
		{
			maxn=l;
		}
		return ;
	}
	for(int i=head[pos];i!=-1;i=q[i].next)  //从u=1开始,寻找相邻的顶点 ,一直扩散,然后回溯。。。 
	{
		if(vis[q[i].v]==0)
		{
			vis[q[i].v]=1;
		    dfs(q[i].v,l+q[i].l,c+q[i].w);
			vis[q[i].v]=0;
		}
	}
	return;
}
int main()
{
	while(~scanf("%d",&k))
	{
		maxn=inf;
		len=0;
		memset(head,-1,sizeof(head));
		memset(vis,0,sizeof(vis));
		scanf("%d",&n);
		scanf("%d",&r);
		int a,b,c,d;
		for(int i=0;i<r;i++)
		{
			scanf("%d%d%d%d",&a,&b,&c,&d);
			creat(a,b,c,d);
		}
	    dfs(1,0,0);
	    if(maxn==inf)
		      printf("-1\n");
		else printf("%d\n",maxn);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值