POJ - 1125 Stockbroker Grapevine (floyd+判断从某一源点是否走完所有点)

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output
3 2
3 10
题意:你的程序将输入不同组股票经纪人的数据。每套都以一系列股票经纪人开始。接下来是每个股票经纪人的一条线,其中包含他们接触的人数,这些人是谁,以及他们将信息传递给每个人的时间。每个股票经纪行的格式如下:行开始于联系人数量(n),随后是n对整数,每个联系人一对。每一对首先列出一个指向联系人的号码(例如,'1'表示集合中第一个人),然后是以分钟为单位向该人传递信息的时间。没有特殊的标点符号或间隔规则。

每个人被编号1到股票经纪人的数量。传递消息的时间将在1到10分钟(含)之间,联系人的数量将介于0到1之间,小于股票经纪人的数量。股票经纪人的数量将在1到100之间。投资由一组包含0(零)人的股票经纪人终止。

解析:数据不算太大,直接用Floyd求出最短距离。问题是,怎样判断从某一源点走完全程呢?这就需要维护一个最大值,即最长的就是走完全程(如果是INF呢,就需要特别处理一下,但这个题数据比较水,不存在不相通的情况)。

#include<stdio.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int n,m;
int e[220][220];
void floyd()
{
    int i,j,k;
    for(k=1; k<=n; k++)
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                if(e[i][j]>e[i][k]+e[k][j])
                    e[i][j]=e[i][k]+e[k][j];
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
            if(i==j)e[i][j]=0;
           else e[i][j]=inf;
           int v,w;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&m);
            for(int j=1;j<=m;j++)
            {
                scanf("%d%d",&v,&w);
                e[i][v]=w;
            }
        }
        floyd();
        int minn;
        int ans=inf;
        int f=1,k;
        for(int i=1;i<=n;i++)
        {
            minn=-1;          //找从某一出发用时最长的,就是走完了所有点
            for(int j=1;j<=n;j++)
            {
                if(i==j)continue;
                minn=max(e[i][j],minn);
            }
            if(ans>minn)      //找符合题意的最小值
            {
                f=0;
                ans=minn;
                k=i;
            }
        }
        if(f==0)printf("%d %d\n",k,ans);
        else printf("disjoint\n"); //可以不写
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值