FZU - 2271—X(Floyd)

X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

Input

The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

Output

For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.

Sample Input
2
2 3
1 2 1
1 2 1
1 2 2
3 3
1 2 1
2 3 1
1 3 1
Sample Output
Case 1: 2
Case 2: 0

题意:N个城市,M个双向道路。任意两个城市都是互相联通的,问,最多能删除几条多余的路,保证任意两个城市间的最短路程不变。

题解:用Floyd求出任意两个城市间的最短路,再枚举:

1.直接相连的路小于求出的最短路。(删1)

2.通过中间城市的路程等于直接相连的路程(删1)

特别判断,两个城市间可能有多条路,删掉重复的、

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f
#include<algorithm>
using namespace std;
int t,n,m;
int e[200][200];
int mp[200][200];
void floyd()
{
    for(int k=1; k<=n; k++)
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(e[i][j]>e[i][k]+e[k][j])
                    e[i][j]=e[i][k]+e[k][j];
}
int main()
{
    int f=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int u,v,l;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(i==j)e[i][j]=0;
                else e[i][j]=inf;
        int cnt=0;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&u,&v,&l);
            if(e[u][v]!=inf)cnt++;
            if(e[u][v]>l)
                e[u][v]=e[v][u]=l;
        }
        memcpy(mp,e,sizeof(mp));   ///复制一下地图
        floyd();
       for(int i=1; i<=n; i++)
            for(int j=i+1; j<=n; j++)
                for(int k=1; k<=n; k++)
                {
                    if(e[i][j]<mp[i][j]&&mp[i][j]!=inf&&i!=j&&i!=k&&k!=j)
                    {
                        cnt++;
                        break;
                    }
                    if(e[i][j]==e[i][k]+e[k][j]&&mp[i][j]!=inf&&i!=j&&i!=k&&k!=j)///注:这里是e[i][k],e[k][j],我在这里WA了好多次
                    {
                        cnt++;
                        break;
                    }
                }
        printf("Case %d: %d\n",f++,cnt);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值