1046. Shortest Distance (20)

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
本题由于图形简单,任意两点之间只有两条路可以选择,而且所有的点又组成了环,这两条路径的和总是等于环的周长,当输入完毕时,我们就可以知道整个环的“周长”,同时在输入时记录每个点到起点(第一个点)的距离,测试时,用两点到起点的距离相减就是两点之间的距离dis,同时,用周长减去dis就是第二条路径的长度,输出两者中较小者即可。
#include <cstdio>

using namespace std;
#define BIG 100001

int min(int a,int b){
	if(a >= b)
		return b;
	else 
		return a;
}

int main(){
	int sum = 0, toFirst[BIG];
	int m,n,a,b,temp = 0,to;
	scanf("%d",&n);

	toFirst[1] = 0;
	for (int i = 2; i <= n; ++i)
	{
		scanf("%d",&temp);
		toFirst[i] = toFirst[i-1] + temp;//每个点到第一个点的距离
		sum += temp;
	}
	scanf("%d",&temp);
	sum += temp;//周长

	scanf("%d",&m);
	for(int i=1;i<=m;i++){
		scanf("%d %d",&a,&b);
		if(a > b){
			a ^= b ^= a ^= b;//交换a和b的值
		}
		printf("%d\n", min(toFirst[b]-toFirst[a], sum-(toFirst[b]-toFirst[a]) ) );
	}

	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值