1050. String Subtraction (20)

1050. String Subtraction (20)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
这道题暴力比较的复杂度时n^2,实不可取,应该用空间换时间,利用一个大小为256的数组exist,首先遍历s2,让s2中出现的字符k对应的ascii码在数组中标记为1,即exist【k】 = 1,然后遍历s1,每个字符k,若exist【k】==1则不输出,否则输出,这样复杂度为n,可以过。
#include <stdio.h>
#include <string.h>

int main(){
	int exist[256], len, i;
	char s2[10001], s1[10001];
	memset(exist, 0, sizeof(int)*256);
	gets(s1);
	gets(s2);

	len = strlen(s2);
	for(i=0;i<len;i++){
		exist[s2[i]] = 1;
	}

	len = strlen(s1);
	for(i=0;i<len;i++){
		if(exist[s1[i]] == 0)
			printf("%c",s1[i]);
	}
	printf("\n");
	return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值