1059. Prime Factors (25)

1059. Prime Factors (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

先生成素数表,然后从表格中逐个检查是否有素数

#include <cstdio>
#include <cmath>
#include <cstring>

using namespace std;

int table[100000];
int factor[100000];

void primeTable(int up){
	memset(table,1,sizeof(int)*100000);
	table[0] = table[1] = 0;
	for(int i=2;i<=sqrt(up);i++){
		if(table[i] == 0)
			continue;
		for(int j=i;i*j<=up;++j){
			table[i*j] = 0;
		}
	}
	return ;
}

int main(){
	int n, sqrt_n;
	int flag = 0;
	scanf("%d",&n);
	printf("%d=",n);
	if(n == 1)
		printf("1\n");
	sqrt_n = int(sqrt(n));

	primeTable(sqrt_n);
	/*for(int i=0;i<sqrt_n;i++){
		if(table[i])
			printf("%d ",i);
	}*/
	for(int i=2;i<=sqrt_n;i++){
		if(table[i] == 0)
			continue;
		while(n%i == 0){
			factor[i]++;
			n/=i;
		}
		if(n==1)
			break;
	}
	for(int i=2;i<=sqrt_n;i++){
		if(factor[i]){
			if(flag)
				printf("*");
			printf("%d",i);
			flag = 1;
		}
		if(factor[i] > 1)
			printf("^%d",factor[i]);
	}
	if(n != 1){
		if(flag)
			printf("*");
		printf("%d",n);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值