1049. Counting Ones (30)

1049. Counting Ones (30)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:
12
Sample Output:
5
这道题更多的是数学思维,和算法好像关系不大,不过在《编程之美》中貌似看到过一道非常类似的题目。计算时,按照:当个位=1时,其他位共有多少种组合,当十位为1时,有其他位有多少种排列组合。。。当最高位为1时,其他位都多少种排列组合。最后加和。具体操作时,当第k位为1时,分为三种情况:
1、若给出的数num,第k位原本就是1,则如何如何(具体见代码)。
2、若给出的数中,第k位原本大于1,则如何如如何。
3、若给出的数中,第k位原本为0,则如何如何.
#include<iostream>
#include<string>
#include<cmath>
using namespace std;

int toNum(string str, int a, int b){
	int ans = 0, i = a;
	for (int i = a; i <= b; i++){
		ans = ans * 10 + str[i] - '0';
	}
	return ans;
}

int main(){
	string num;
	int pre, post, ans = 0;
	cin >> num;
	int len = num.size();
	for (int i = 0; i < len; i++){
		pre = toNum(num, 0, i - 1) + 1;
		post = pow(10, len - i - 1);
		if (num[i] == '0'){
			pre--;
			ans += pre * post;
		}
		else if (num[i] == '1'){
			ans += (pre - 1)*pow(10, len - i - 1) + toNum(num, i + 1, len - 1) + 1;
		}
		else if (num[i] > '1'){
			ans += pre * post;
		}
	}
	cout << ans << endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值