[动态规划]UVA10003 - Cutting Sticks


  Cutting Sticks 

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input 

The input will consist of several input cases. The first line of each test case will contain a positive number  l  that represents the length of the stick to be cut. You can assume  l  < 1000. The next line will contain the number  n  ( n  < 50) of cuts to be made.

The next line consists of n positive numbers ci ( 0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.

An input case with l = 0 will represent the end of the input.

Output 

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input 

100
3
25 50 75
10
4
4 5 7 8
0

Sample Output 

The minimum cutting is 200.
The minimum cutting is 22.



Miguel Revilla 
2000-08-21

题意:

你的任务是替一家叫Analog Cutting Machinery (ACM)的公司切割木棍。切割木棍的成本是根据木棍的长度而定。而且切割木棍的时候每次只切一段。

很显然的,不同切割的顺序会有不同的成本。例如:有一根长10公尺的木棍必须在第2、4、7公尺的地方切割。这个时候就有几种选择了。你可以选择先切2公尺的地方,然后切4公尺的地方,最后切7公尺的地方。这样的选择其成本为:10+8+6=24。因为第一次切时木棍长10公尺,第二次切时木棍长8公尺,第三次切时木棍长6公尺。但是如果你选择先切4公尺的地方,然后切2公尺的地方,最后切7公尺的地方,其成本为:10+4+6=20,这成本就是一个较好的选择。

你的老板相信你的电脑能力一定可以找出切割一木棍所需最小的成本。

思路:典型的动态规划题目,有点像矩阵链乘问题,找到状态转移公式就好了dp[i][j]=max{dp[i][k]+dp[k][j]+len[j]-len[i]|i<k<j}

#include<iostream>
#include<cstring>

using namespace std;

const int maxn=100000;
int pos[60];
int dp[60][60];

int main()
    {
        int len,num;
        while(cin>>len&&len)
            {
                cin>>num;
                int i,j,k,l;
                int cost;
                memset(dp,0,sizeof(dp));
                for(i=1;i<=num;i++)
                    cin>>pos[i];
                pos[0]=0,pos[num+1]=len;
                for(l=2;l<=num+1;l++)
                    {
                        for(i=0;i+l<=num+1;i++)
                            {
                                j=i+l;
                                dp[i][j]=maxn;
                                for(k=i+1;k<j;k++)
                                    {
                                        cost=dp[i][k]+dp[k][j]+pos[j]-pos[i];
                                        if(cost<dp[i][j]) dp[i][j]=cost;
                                    }
                            }
                    }
                cout<<"The minimum cutting is ";
                cout<<dp[0][num+1]<<"."<<endl;
            }
        return 0;
    }


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值