Fzu1759 Super A^B mod C

Super A^B mod C

Time Limit:1000MS    Memory Limit:32768KB

   64bit IO Format:%I64d & %I64u

Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,C<=1000000000,1<=B<=10^1000000).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 4
2 10 1000

Sample Output

1
24

(A ^ B )% C = (A ^ (B % Phi(C) + Phi(C))) % C    其中(B >=Phi(C)) 
Phi(C) 为欧拉值
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
long long a, c;
long long eular(long long n)
{
	long long ans = n, res = n;
	for(int i = 2; i * i <= n; ++ i)
	{
		if(res % i == 0)
		{
			ans = ans / i * (i - 1);
			while(res % i == 0)
			{
				res /= i;
			}
		}
	}
	if(res > 1)
		ans = ans / res * (res - 1);
	return ans;

}
long long Power(long long a, long long b)
{
	long long ans = 1;
	while(b)
	{
		if(b & 1)
			ans = (ans % c) *( a % c) % c;
		b >>= 1;
		a = (a % c )* (a % c) % c;
	}
	return ans % c;
}

char b[1000005];
int main()
{
	
	while(~scanf("%lld%s%lld", &a, b,&c))
	{
		long long x = eular(c);
		long long s = 0;
		int len = strlen(b);
		if(len <= 10)
		{
			for(int i = 0; b[i]; ++ i)
			{
				s = s * 10 + b[i] - '0';
			}
			if(s < x)
			{
				printf("%lld\n", Power(a, s) % c);
				continue;
			}
		}
		s = 0;
		for(int i = 0; b[i]; ++ i)
		{
			s = s * 10 + b[i] - '0';
			s %= x;
		}
		printf("%lld\n", Power(a, s + x) % c);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值