poj2411Mondriaan's Dream(状态压缩dp)

Mondriaan's Dream Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Appoint description:

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

用2进制的01表示不放还是放
第i行只和i-1行有关
枚举i-1行的每个状态,推出由此状态能达到的i行状态
如果i-1行的出发状态某处未放,必然要在i行放一个竖的方块,所以我对上一行状态按位取反之后的状态就是放置了竖方块的状态。
然后用搜索扫一道在i行放横着的方块的所有可能,并且把这些状态累加上i-1的出发状态的方法数,如果该方法数为0,直接continue。




#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<set>
#include <queue>
#include<algorithm>
#include <vector>
const double PI = acos(-1.0);
using namespace std;
long long dp[15][1 << 12], tep;//用tep记录上一行每个状态的dp值
int h, w;
void dfs(int a, int b, int c) //a为行, b为该行的状态, c为该行第几列
{
	if(c >= w)
	{
		dp[a][b] += tep;
		return;
	}
	dfs(a, b, c + 1);
	if(c + 2 <= w && ! (b & (1 <<c)) && !(b & (1 << (c + 1))))
		dfs(a, b + (1 << c) + (1 << (c + 1)), c + 2);
}
int main()
{
	int  i, j, k;
	while(scanf("%d%d", &h, &w) && (h + w))
	{
		if((h & 1) && (w & 1))
		{
			printf("0\n");
			continue;
		}
		memset(dp, 0, sizeof(dp));
		tep = 1;
		dfs(1, 0, 0);
		for(i = 2; i <= h; ++ i)
		{
			for(j = 0; j < (1 << w); ++ j)
			{
				if(dp[i - 1][j])
					tep = dp[i - 1][j];
				else
					continue;
				dfs(i, ~j & ((1 << w) - 1), 0);//注意取反不能直接加~.
			}
		}
		printf("%lld\n", dp[h][(1 << w) - 1]);
	}
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值