树的遍历 有后序遍历和中序遍历建立二叉树,并输出层次遍历

树的遍历   (25分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数NN(\le 30≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

 

#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <string>
#include <cstring>
#include <sstream>

using namespace std;
int n;
int hou[50];
int zhong[50];

struct Btree
{
    int data;
    Btree* left;
    Btree* right;
};
typedef struct Btree Btree;

int findindex(int *zhong,int x,int len)
{
    for(int i=0;i<len;i++)
    {
        if(zhong[i]==x)
        {
            return i;
        }
    }
}

Btree* build(int *hou,int *zhong,int len)
{
    if(len<=0) return NULL;
    Btree* tmp=new Btree;
    tmp->data=hou[len-1];
    int index=findindex(zhong,hou[len-1],len);
    tmp->left=build(hou,zhong,index);
    tmp->right=build(hou+index,zhong+index+1,len-index-1);
    return tmp;
}
int ans[500];
int cur;

void cenorder(Btree *root)
{
    queue<Btree*> Q;
    Q.push(root);
    while(!Q.empty())
    {
        Btree *tmp=Q.front();
        ans[cur++]=tmp->data;
        if(tmp->left!=NULL)
        {
            Q.push(tmp->left);
        }
        if(tmp->right!=NULL)
        {
            Q.push(tmp->right);
        }
        Q.pop();
    }
}

int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&hou[i]);
    }
    for(int i=0;i<n;i++)
    {
        scanf("%d",&zhong[i]);
    }
    Btree *root=build(hou,zhong,n);
    cenorder(root);
    for(int i=0;i<n;i++)
    {
        if(i==0) printf("%d",ans[i]);
        else printf(" %d",ans[i]);
    }
    printf("\n");
    return 0;
}


 

 

  • 3
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值