Bone Collector

Problem Description
 
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
 
The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
 
One integer per line representing the maximum of the total value (this number will be less than 2[sup]31[/sup]).
 

Sample Input
 
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
 
  
  
14
 题解:0-1背包,注意,0-1背包遍历大方向。
 

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
int f[2000];
int val[2000];
int cos[2000];
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		memset(f,0,sizeof(f));
		memset(val,0,sizeof(val));
		memset(cos,0,sizeof(cos));
		int n,v;
		scanf("%d%d",&n,&v);
		int i,j;
		for(i=1;i<=n;i++)
		  scanf("%d",&val[i]);
		for(j=1;j<=n;j++)
		  scanf("%d",&cos[j]);
		for(i=1;i<=n;i++)
		{
			for(j=v;j>=cos[i];j--)
			{
			  //if(j>=cos[i])
			    f[j]=max(f[j],f[j-cos[i]]+val[i]);
			} 
		}
	printf("%d\n",f[v]);	
	}
	return 0;
}


#include<stdio.h>
#include<string.h>
#define MAX(a,b) (a>b?a:b)
int val[2000];//骨头的价值 
int cos[2000];//骨头的体积 
//int f[200][200];开的太小了(第一处错误) 
<span style="color:#ff0000;">int f[2000][2000]; //f[i][v]表示前i件物品恰放入一个容量为v的背包可以获得的最大价值 
</span>int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		memset(val,0,sizeof(val));
		memset(cos,0,sizeof(cos));
		memset(f,0,sizeof(f));
		int n,v;
		scanf("%d%d",&n,&v);
		for(int i=1;i<=n;i++)
		  scanf("%d",&val[i]);
		for(int j=1;j<=n;j++)
		   scanf("%d",&cos[j]);
		<span style="color:#009900;">for(int i=1;i<=n;i++)//将1-n件物品依此判断是否放入背包。 
</span>		{
			//for(int j=1;j<=v;j++)
			<span style="color:#ff0000;">for(int j=0;j<=v;j++)//顺序遍历时,是从0开始遍历的(第二处错误)。 
</span>			{
				f[i][j]=f[i-1][j];
				if(j>=cos[i])
			      f[i][j]=MAX(f[i-1][j],f[i-1][j-cos[i]]+val[i]); 
			}
		}
		printf("%d\n",f[n][v]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值