1046. Shortest Distance (20)—PAT

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
推荐指数:※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1046
通过两个点到起点的距离相减得到之间的距离。这个距离与环的另一部分距离比较得到答案。
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
using namespace std;
int main()
{
	int n,i,sum=0;
	scanf("%d",&n);
	int *dis=new int[n+1];
	int *dis_sum=new int[n+1];
	dis_sum[1]=0;
	for(i=1;i<=n;i++){
		scanf("%d",&dis[i]);
		sum+=dis[i];
		if(i!=1)
			dis_sum[i]=dis_sum[i-1]+dis[i-1];
	}
	int m;
	scanf("%d",&m);
	for(i=0;i<m;i++){
		int a,b,shortest;
		scanf("%d%d",&a,&b);
		shortest=dis_sum[max(a,b)]-dis_sum[min(a,b)];
		printf("%d\n",shortest<(sum-shortest)?shortest:(sum-shortest));
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值