百练oj 2757 最长上升子序列

2757:最长上升子序列

总时间限制: 
2000ms 
内存限制: 
65536kB
描述
一个数的序列 bi,当 b1 <  b2 < ... <  bS的时候,我们称这个序列是上升的。对于给定的一个序列( a1a2, ...,  aN),我们可以得到一些上升的子序列( ai1ai2, ...,  aiK),这里1 <=  i1 <  i2 < ... <  iK <= N。比如,对于序列(1, 7, 3, 5, 9, 4, 8),有它的一些上升子序列,如(1, 7), (3, 4, 8)等等。这些子序列中最长的长度是4,比如子序列(1, 3, 5, 8).

你的任务,就是对于给定的序列,求出最长上升子序列的长度。
输入
输入的第一行是序列的长度N (1 <= N <= 1000)。第二行给出序列中的N个整数,这些整数的取值范围都在0到10000。
输出
最长上升子序列的长度。
样例输入
7
1 7 3 5 9 4 8
样例输出
4
来源

翻译自 Northeastern Europe 2002, Far-Eastern Subregion 的比赛试题

ACcode:

#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 1005
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
int dp[maxn],a[maxn];
int main(){
    int n;
    while(rd(n)!=EOF){
        FOR(i,1,n){
            rd(a[i]);
            dp[i]=1;
        }
        FOR(i,2,n){
            FOR(j,1,i-1){
                if(a[j]<a[i])
                    dp[i]=max(dp[i],dp[j]+1);
            }
        }
        cout<<*max_element(dp+1,dp+n+1);
    }
    return 0;
}
/*
7
1 7 3 5 9 4 8
*/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值