Hduoj1025【最长上升子序列 + 二分】

/*Constructing Roads In JGShining's Kingdom 
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.
Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). 
Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no 
two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 
With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to 
ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna 
build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, 
any rich city will be willing to export resource to any poor one.
Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 
The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich 
City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 
But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.
For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p 
and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output
For each test case, output the result in the form of sample. 
You should tell JGShining what's the maximal number of road(s) can be built. 

Sample Input
2
1 2
2 1
3
1 2
2 3
3 1

Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

Hint
Huge input, scanf is recommended. 
Author
JGShining(极光炫影) 
*/
#include<stdio.h>
#include<string.h>
int a[500100], b[500100];
void replace(int x, int y, int z)
{
	int mid = (x+y) / 2 , i;
	for(i = x; i <= mid; ++i)//left
	{
		if(z < b[i])
		{
			b[i] = z;
			return;
		}
	}
	replace(mid+1, y, z);//right
}
int Dp(int x)
{
	int i, j , p = 0;
	memset(b, 0, sizeof(b));
	for(i = 1; i <= x; ++i)
	{
		if(!b[0])
		{
			b[0]++;
			b[b[0]] = a[i];
		}
		else
		{
			if(a[i] > b[b[0]])//the most big
			{
				b[0]++;
				b[b[0]] = a[i];
			}
			else//replace
			{
				replace(1 , b[0], a[i]);
			}
		}
	}
	return b[0];
}
int main()
{
	int i, j, k, n, cas = 1;
	while(scanf("%d", &n) != EOF)
	{
		memset(a, 0, sizeof(a));
		for(i = 1; i <= n; ++i)
		{
			scanf("%d %d", &j, &k);
			a[j] = k;
		}
		k = Dp(n);
		printf("Case %d:\n", cas++);
		if(k == 1)
		printf("My king, at most 1 road can be built.\n");
		else
		printf("My king, at most %d roads can be built.\n", k);
		printf("\n");
	}
	return 0;
}


题意:给出2排序列,分别都从1~n,并且给出配对,求能得到最多的配对数,但要求配对数中不能有交叉出现。

思路:标准的最长上升子序列,方法就是将输入的配对用一个a数组来保存,1~n保存各自对应给出的配对,接着从1~n开始循环,另外开一个b数组保存最终的配对答案。则有以下3种情况1:数组b中没有配对,直接将a【i】保存进b数组;2:如果遇到a【i】大于所有b数组中的配对,则直接将a【i】插入到b末尾;3:a【i】小于b中的最大值,则要用二分法搜索出b数组中第一个比a【i】大的数,并用a【i】将其替换。最后b数组所保存的个数即为最终的配对。

难点:该题的难点在于二分,一般情况下是不会用二分,而是直接插入的,但是该题会超时。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值