HDU 3866 Moonfang's Birthday(贪心)

Description

It's Moonfang's birthday,and his friends decided to buy him a copy of XianJianQiXiaZhuan V. 
   
Since some of friends have more money available than others, nobody has to pay more than he can afford. Every contribution will be a multiple of 1 cent,i.e.,nobody can pay fractions of a cent. 
   
Everybody writes down the maxumum amount he is able to contribute. Taking into account these maximum amounts from everybody, your task is to share the cost of the present as fairly as possible. That means, you minimize the largest distance of the contributions to 1/n-th of the total cost. 
   
In case of a tie, minimize the second largest distance, and so on. Since the smallest unit of contribution is 1 cent, there might be more than one possible division of the cost. In that case, persons with a higher maximum amount pay more. If there is still ambiguity, those who come first in the list pay more. 
   
Since you bought the present, it is your task to figure out how much everybody has to pay.

Input

On the first line a positive integer: the number of test cases, at most 200. After that per test case: 
  • One line with two integers p and n: the price of the present in cents (1 ≤ p ≤ 1 000 000) and the number of people (2 ≤ n ≤ 10000) who contribute to the present (including you).
  • One line with n integers ai (1 ≤ ai ≤ 1 000 000), where ai is the maximum amount, in cents, that the i-th person on the list is able to contribute.

Output

Per test case: 
  • One line with n integers: the amounts each person has to contribute according to the scheme. If the total cost cannot be divided according to the above rules, the line must contain "IMPOSSIBLE" instead.

Sample Input

3 
20 4 
10 10 4 4 
7 3 
1 1 4 
34 5 
9 8 9 9 4

Sample Output

6 6 4 4 
IMPOSSIBLE 
8 7 8 7 4 

一群人聚会,有花费总钱数,有每个人有的钱数,让你计算在保证出钱最多的人跟最小的人差值最小的情况下,每个人应该出多少钱。

思路:先排序,计算每个人应该平均付多少per(时刻变化的),看钱数最少的人如果他拥有的钱数少于per,那就把自己的钱全部拿出来,然后人数少一个,继续计算剩下的人每个人应该拿出多少per,每次拿出钱的人记录他的位置与拿出的钱数,最后顺序输出就行了。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stack>
#include <vector>
#include <queue>
#include <iostream>
#define _LL __int64
using namespace std;
struct node
{
    int p;
    int index;
}a[100005];
int cmp(node a,node b)
{
    if(a.p==b.p)
        return a.index > b.index;
    return a.p < b.p;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int b[100000];
        int ps,n;
        long long z=0;
        scanf("%d%d",&ps,&n);
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&a[i].p);
            a[i].index=i;
            z+=a[i].p;
        }
        if(z < ps)
        {
            cout<<"IMPOSSIBLE"<<endl;
            continue;
        }
        sort(a+1,a+n+1,cmp);
        int pop=n;
        for(int i = 1;i <= n;i++)
        {
            int x=ps/pop;
            if(a[i].p < x)
            {
                ps-=a[i].p;
                b[a[i].index]=a[i].p;
            }
            else
            {
                b[a[i].index]=x;
                ps-=x;
            }
            pop--;
        }
        for(int i = 1;i <= n;i++)
        {
            if(i >= 2)
                cout<<" ";
            cout<<b[i];
        }
        cout<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值