Splits the string

Splits the string
时间限制:1000 ms | 内存限制:65535 KB
难度:3
描述
Hrdv is interested in a string,especially the palindrome string.So he wants some palindrome string.

A sequence of characters is a palindrome if it is the same written forwards and backwards. For example, ‘abeba’ is a palindrome, but ‘abcd’ is not.

A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, (‘race’, ‘car’) is a partition of ‘racecar’ into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

‘racecar’ is already a palindrome, therefore it can be partitioned into one group.
‘fastcar’ does not contain any non-trivial palindromes, so it must be partitioned as (‘f’, ‘a’, ‘s’, ‘t’, ‘c’, ‘a’, ‘r’).
‘aaadbccb’ can be partitioned as (‘aaa’, ‘d’, ‘bccb’).
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

输入
Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.
输出
For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.
样例输入
racecar
fastcar
aaadbccb
样例输出
1
7
3

我的代码:

#include <iostream>
#include <cstring>
using namespace std;
#define min(a,b) a>b?b:a 
char str[1001];
int dp[1001];
int judge(int x,int y)//判断是否是回文串
{
    while (x<=y)
    {
        if(str[x]!=str[y])return 0;//不是就返回0
        x++;y--;
    }
    return 1;
}
int main()
{
    int i,j,k;
    while (cin >> str)
    {
        k=strlen(str);
        i=0;
        while (i<k)
        {
            dp[i]=i+1;//最坏的情况为字符自身长度
            for (j=0;j<=i;++j)
            {
                if(str[j]==str[i]&&judge(j,i))
                    dp[i]=min(dp[i],dp[j-1]+1);//后一个的状态需要前一个决定
            }
            i++;
        }
        cout << dp[k-1] << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值