nyoj Splits the string 749 (区间dp)

                                                      Splits the string
时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Hrdv is interested in a string,especially the palindrome string.So he wants some palindrome string.

A sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'abeba' is a palindrome, but 'abcd' is not.

A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

'racecar' is already a palindrome, therefore it can be partitioned into one group.
'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

输入
Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.
输出
For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.
样例输入
racecar
fastcar
aaadbccb
样例输出

1 7 3

//思路:
//dp[i]表示从1到i之间的最少回文串的个数 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[1010];
int dp[1010];
bool judge(int l,int r)
{
	while(l<=r)
	{
		if(s[l++]!=s[r--])
			return false;
	}
	return true;
}
int main()
{
	int l,i,j;
	while(scanf("%s",s+1)!=EOF)
	{
		l=strlen(s+1);
		for(i=1;i<=l;i++)
		{
			dp[i]=i;
			for(j=1;j<=i;j++)
			{
				if(s[i]==s[j]&&judge(j,i))
				{
					dp[i]=min(dp[i],dp[j-1]+1);
				}
			}
		}
		printf("%d\n",dp[l]);
	}
	return 0;
}


 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值