POJ:3069 Saruman's Army(贪心)

Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6801 Accepted: 3493

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source



题目大意:给你n个点的坐标,给你个R,在这n个点中选取若干点标记。标记后,对于所有的点,在与其距离为R的区域内必须有被标记的点,求所被标记的点的最少个数。
思路:将这些数字存入数组,从小到达排序,然后看代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
int a[1010];
int main()
{
	int r,n;
	while(scanf("%d%d",&r,&n)!=EOF)
	{
		if(r==-1&&n==-1)
		break;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		sort(a,a+n);
		int i=0;
		int cnt=0;
		while(i<n)
		{
			int s=a[i];//是为起点 
			i++;
			while(s+r>=a[i]&&i<n)//找起点+r所不能及的最近点坐标,那么找出来后那个坐标的之前那个坐标就为所应标记的点 
			{
				i++;
			}
			int p=a[i-1];//p为所标记的点 
			while(p+r>=a[i]&&i>n)//找到p点所不能及的最近的点,该点作为下次循环的起点 
			{
				i++;
			}
			cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}


























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值