POJ 3069-Saruman's Army [贪心] 《挑战程序设计竞赛》2.2

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006

题目大意:

直线上有N个点。点i的位置是Xi。从这N个点钟选择若干个,给他们加上标记。对每一个点,其距离为R以内的区域里必须有带有标记的点(自己本身带有标记的点,可以认为与其距离为0的地方有一个带有标记的点)。在满足这个条件的情况下,希望能尽量少的添加标记。请问至少要有多少点被加上标记。

题解:

贪心法, 先排序,从最左边开始向右找,找到最右边的,能覆盖最左边的点的位置, 选择这个点。然后选中的这个点所能覆盖的范围之内的点就不予考虑了,最左边的点变为刚刚选中的点的范围之外的第一个点,重复刚才的过程,选择最右边的可以覆盖刚刚被选择的点的位置,标记之……

代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#define MAX_N 1010
using namespace std;
int R, n;
int a[MAX_N];
bool f[MAX_N];
int main() {
    while (cin >> R >> n) {
        if (R == -1 && n == -1) break;
        memset(f, false, sizeof(f));
        for (int i = 0; i < n; i++) cin >> a[i];
        sort(a, a+n);
        int ans = 0;
        for (int i = 0; i < n; i++) if (!f[i]) { 
            f[i] = true;
            //找到可以覆盖上一个标记点的位置 
            int k = i;
            for (int j = i; j < n; j++) {
                if (a[j] - R <= a[i]) k = j;
                else break;
            }
            ans++;
            i = k;
            //然后刚选中的标记点可以覆盖的位置就不用考虑了 
            for (int j = k+1; j < n; j++) {
                if (a[k] + R >= a[j]) i = j;
                else break; 
            }
        }
        cout << ans << endl;

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值