week12 作业D选做题1

选做题 - 1

We give the following inductive definition of a “regular brackets” sequence:
the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

我的思路:
这道题是要计算出当前字符串的满足要求的最长子序列。这道题是要用区间DP,整体思路是从满足条件的小区间最大逐渐加到大区间最大,从而得出结果。在状态转移方程的实现方面,对于起始位置和终止位置的字符分别是 ‘(‘和’)’ 或 ‘[‘和’]’ ,则直接在(起始位置+1,终止位置-1)的dp值基础上加2,其他的则找区间内分成 两半的小区间的值之 和 自身大小 取最大值作为当前大区间的值,然后按照这样的方法直到计算出整个全部区间为止,即为最后的结果。

我的总结:
这道题是区间DP,思路是很重要,需要想明确状态的转移,以及从小区间扩展到大区间的思想。

我的代码:

#include<iostream>
#include<cstring>
using namespace std;

long long dp[200][200];
string st;


int main()
{
	while(1)
	{
		cin>>st;
		if(st=="end") break;
		memset(dp,0,sizeof(dp));
		int len = st.size();
		for(int l=2;l<=len;l++)
		{
			for(int i=0;i+l<=len;i++)
			{
				int j = i+l-1;
				if((st[i]=='('&&st[j]==')') || (st[i]=='['&&st[j]==']')) dp[i][j]=dp[i+1][j-1]+2;
				for(int k=i;k<j;k++)
					dp[i][j] = max(dp[i][j],dp[i][k]+dp[k+1][j]);
			}
		}
		cout<<dp[0][len-1]<<endl;
	}
	return 0}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值