POJ:1328 Radar Installation(贪心)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 75336 Accepted: 16857

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source




题目大意:
给你一个数字n和d,n代表小岛的个数,d代表雷达所能覆盖的半径,接下来n行,表示每个小岛的坐标,问最少需要多少个雷达能覆盖全部小岛(雷达在x轴上)。

解题思路:
求出能覆盖每个点的圆的左区域和有区域,然后从左往右扫描,能覆盖的话就继续扫,不能覆盖的话就cnt+1。

代码如下:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#define INF 100000000
using namespace std;
struct node
{
    double start, end;//包含每个点的圆的左右区间 
};
node num[1010];
bool cmp(node a, node b)
{
    return a.end < b.end;
}
int main()
{
    int N, k = 1;
    double d;
    while(scanf("%d%lf", &N, &d), N||d)
    {
        double x, y;
        int bukeneng=0;
        for(int i = 0; i < N; i++)
        {
            scanf("%lf%lf", &x, &y);
            if(bukeneng==1) continue;
            if(y > d)
            {
                bukeneng=1;
                continue;
            }
            num[i].start = x - sqrt(d * d - y * y);
            num[i].end = x + sqrt(d * d - y * y);
        }
        printf("Case %d: ", k++);
        if(bukeneng==1)
        {
            printf("-1\n");
            continue;
        }
        sort(num, num+N, cmp);
        int ans = 0;
        double temp = -INF;//初始化前键 
        for(int i = 0; i < N; i++)
        {
            if(temp < num[i].start)
            {
            	ans++;
				temp = num[i].end;
			}
        }
        printf("%d\n", ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值