HDU:1394 Minimum Inversion Number(树状数组+逆序对)

5 篇文章 0 订阅
2 篇文章 0 订阅

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18251    Accepted Submission(s): 11083


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1698  1540  1542  1255  1754 

题目大意:给你一个序列,每次将这个序列的最后一个元素移到第一位,问这些过程中,所生成的每种序列,最小的逆序对数为多少,输出这个最小逆序对数。
解题思路:先用树状数组求出原始序列的逆序对数,然后开始移动最后一位,把a[n]移到第一位,逆序对增加a[i]-1,逆序对减少n-a[i](因为这道题给出一个n,那么下面的序列元素值的范围是0~n-1的,且不重复,所以有刚才那个结论),然后每次移动更新ans就行。注意这里元素可以是0,而树状数组不能处理角标为0的情况,所以这里每次a[i]+1就没事了。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[5010];
int c[5010];
int n;
void update(int x)
{
	while(x<=n)
	{
		c[x]=c[x]+1;
		x=x+(x&(-x));
	}
}
int cnt(int x)
{
	int s=0;
	while(x>0)
	{
		s=s+c[x];
		x=x-(x&(-x));
	}
	return s;
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(c,0,sizeof(c));
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			a[i]++;//树状数组不能处理角标为0的情况,所以这里每次a[i]+1就没事了
			update(a[i]);
			sum=sum+i-cnt(a[i]);//边插入元素边求逆序对数 
		}
		int ans=sum;
		for(int i=n;i>1;i--)//从后开始往前放置 
		{
			sum=sum+(a[i]-1)-(n-a[i]);//把a[n]移到第一位,逆序对增加a[i]-1,逆序对减少n-a[i]
			ans=min(ans,sum);//更新ans 
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值