HDU:1501 Zipper(DFS+剪枝)

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9915    Accepted Submission(s): 3550


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no
 

Source
 

Recommend

linle

题目大意:给你s1 s2 s3三个字符串,问你s1 s2能否组成s3(保证s3的长度是s1与s2的长度之和,组成s3的时候可以随意选择s1,s2的字母,不过得保持原s1、s2的字母前后顺序)

解题思路:深搜,设置i,j,k三个变量为s1 s2 s3的角标,如果s3[k]=s1[i],那么搜i+1,j,k+1,如果s3[k]=s2[j],那么搜i,j+1,k+1,如果两个都一样,那么都搜。加一个visit数组标记i,j这种状态是否访问过(剪枝)。

代码如下:

#include <cstdio>
#include <cstring>
char s1[410],s2[410],s3[410];
int visit[410][410];
int len1,len2,len3;
int flag;
void dfs(int i,int j,int k)
{
	if(flag==1||visit[i][j]==1)
	{
		return ;
	}
	if(k==len3)
	{
		flag=1;
		return ;
	}
	visit[i][j]=1;
	if(i<len1&&s1[i]==s3[k])
	{
		dfs(i+1,j,k+1);
	}
	if(j<len2&&s2[j]==s3[k])
	{
		dfs(i,j+1,k+1);
	}
}
int main()
{
	int t;
	int cnt=1;
	scanf("%d",&t); 
	while(t--)
	{
		scanf("%s %s %s",s1,s2,s3);
		len1=strlen(s1);
		len2=strlen(s2);
		len3=strlen(s3);
		flag=0;
		memset(visit,0,sizeof(visit));
		dfs(0,0,0);
		if(flag==1)
		{
			printf("Data set %d: yes\n",cnt++);
		}
		else
		{
			printf("Data set %d: no\n",cnt++);
		}
	}
	return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值