HDU:2266 How Many Equations Can You Find(深搜+DFS)

1 篇文章 0 订阅

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 913    Accepted Submission(s): 608


Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
 

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
 

Output
The output contains one line for each data set : the number of ways you can find to make the equation.
 

Sample Input
  
  
123456789 3 21 1
 

Sample Output
  
  
18 1
 

Author
dandelion
 

Source
 

Recommend

lcy


题目大意:给你一个字符串里面都是数字,在这些数字中两两之间加上任意个加减号,可加可不加,问能否得到答案ans,输出方法数。


解题思路:深搜,看代码吧,很简单。


代码如下:

#include <cstdio>
#include <cstring>
#define LL long long
LL cnt;
LL size;
char s[20];
LL ans;
void dfs(LL pos,LL sum)
{
	if(pos==size)//扫完式子,则结束 
	{
		if(sum==ans)//扫完的时候判断是否等于ans 
		{
			cnt++;
		}
		return ;
	}
	LL tmp=0;//中间变量,存pos点后的数的可能情况,因为+、-号可加可不加,下面的数可能是个位、十位、百位。。。
	//用long long是因为题目中说数字最多12位,tmp最多可能存11位了,爆 int了。。 
	for(LL i=pos;i<size;i++)
	{
		tmp=tmp*10+s[i]-'0';
		dfs(i+1,sum+tmp);//注意是i 
		if(pos!=0)//第一位前面不能加减号 
		{
			dfs(i+1,sum-tmp);
		}
	}
}
int main()
{
	while(scanf("%s %lld",s,&ans)!=EOF)
	{
		size=strlen(s);
		cnt=0;
		dfs(0,0);
		printf("%lld\n",cnt);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值