poj 2262 Goldbach's Conjecture(数论、素数筛选)

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 

Every even number greater than 4 can be
written as the sum of two odd prime numbers.


For example: 

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题意:这题其实不难,就是给你一个数,让你找出两个素数加起来的和等于这个数,并且要保证这两个素数的差值最大

大体思路就是先用筛选法构造素数数组,然后遍历即可,但是我在遍历的时候图省事就直接两个循环嵌套,估摸着会超时,还是想试试,果不其然,真超时了。。。。FK,改进了一下,终于没问题了了

附上AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 1000005
long long int a[N];    //大数组的话要设全局变量
int main()
{
	long long int  i,j,k,n,m;
	long long int maxx,maxxi,maxxj;
	memset(a,0,sizeof(a));
	for(i=2;i<N;i++)
	{
		if(!a[i])
		{
			a[i]=i;
			for(j=i+i;j<N;j+=i)
			{
				a[j]=i;
			}
		}
	}
	
	while(scanf("%lld",&n))
	{
		if(n==0) break;
		
		maxx=-1;
		long long count=0;
		for(i=2;i<=n/2;i++) //for循环可以再优化,i=3;i<=n/2;i+=2,自己考虑吧,反正这样也能AC
		{
			if(a[i]+a[n-i]==n)
			{
				printf("%lld = %lld + %lld\n",n,a[i],a[n-i]);//这里其实知道根本就不可能输出                
                                                             //另一个
				break;
			}
		}

	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值